Back to overview
Degraded
OTP deliveribility slower
Oct 8, 2025 at 10:28am UTC
Affected services
App
Resolved
Oct 8, 2025 at 11:32am UTC
We’re back! OTP should be up and running. Thanks for bearing with us.
Affected services
Created
Oct 8, 2025 at 10:28am UTC
We have identitied OTP delivering slowly will be fixed in 10-15 minutes.
Affected services